Degraded Services on affecting Cloudsites

Incident Report for Liquid Web - Cloud Sites

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 11:11 CDT

Monitoring

Services have been restored, and websites are currently loading as expected. Our Network team is continuing to investigate the underlying cause and is actively monitoring the environment to ensure stability.

At this time, all services appear to be operating normally. If you experience any issues or need assistance, please contact our Support team.
Posted Jul 20, 2026 - 06:49 CDT

Identified

The issue has been identified, and our engineering team is actively working on a fix.

If you have any questions, please do not hesitate to get help through LiveChat or by submitting a Case, and our team will be happy to assist you.
Posted Jul 19, 2026 - 22:54 CDT

Investigating

We are currently investigating a Website issue with our Cloud Sites Services, which is impacting our hosting environments. Our engineering team is currently investigating the issue at this time.
Posted Jul 19, 2026 - 22:18 CDT
This incident affected: PHP Services (PHX).