We are currently performing a planned maintenance window to stabilize and enhance the reliability of our network. During this time, some users may experience intermittent connectivity issues.
We appreciate your patience as our team works to complete this maintenance. If you have any questions or need assistance, please chat with us or create a case via my.liquidweb.com.
Posted Mar 25, 2026 - 10:24 CDT
Monitoring
Servers are fully operational. Our Engineers are still mitigating and monitoring the situation. We appreciate your patience and understanding while we work to resolve this issue.
If you have any questions or need assistance, please chat with us or create a case via my.liquidweb.com.
Posted Mar 25, 2026 - 07:37 CDT
Update
We are not seeing any active alerts but continue to investigate the intermittent alerts received.
If you have any questions or need assistance, please chat with us or create a case via my.liquidweb.com.
We will keep this space updated as progress is made.
We appreciate your patience and understanding while we work to resolve this issue. Thank you.
Posted Mar 25, 2026 - 05:58 CDT
Investigating
We are currently investigating network performance issues affecting servers in our Phoenix Data Center. You may experience connectivity disruptions. Our engineers are working to identify the cause and restore stability.
If you have any questions or need assistance, please chat with us or create a case via my.liquidweb.com.
We appreciate your patience and understanding while we work to resolve this issue. Thank you.
Posted Mar 25, 2026 - 05:18 CDT
This incident affects: MariaDB (PHX) and IIS Services (PHX).