Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 28, 2025 - 23:00 CDT
Scheduled
We will be conducting a routine maintenance on a subset of our Netapp infrastructure in order to apply system updates. We do not anticipate any service disruptions as a part of these upgrades. If you do notice any degradation in performance please reach out to our Support Team and we will be happy to assist you.
Posted Aug 22, 2025 - 12:26 CDT
This scheduled maintenance affected: IIS Services (LAN, PHX).