Premium Business Email control panel login issue
Incident Report for Liquid Web - Cloud Sites
Resolved
Our email vendor has resolved the Webmail and Control Panel issues.
Posted Jul 22, 2024 - 12:50 CDT
Update
We have identified an intermittent issue with the webmail access as well. We are engaging with our email vendor to resolve the Email control panel and Webmail login issue.

This may be affecting the ability to manage the emails.

We appreciate your patience in the matter, and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 22, 2024 - 10:08 CDT
Identified
Our Email vendor is actively investigating an issue with the Premium Business Email control panel, and we will provide updates on our status page as more information becomes available.

Please note that mail delivery has not been impacted.

If you have any questions, please contact a member of our support team via chat/ticket or by phone at +1-866-639-2377 (US) or +1-517-322-0434 (international).
Posted Jul 22, 2024 - 07:18 CDT
Investigating
Our teams are currently investigating an issue affecting the Premium Business Email control panel . We will update this status post as more information becomes available.

If you have any questions, please contact a member of our support team via chat/ticket or by phone at +1-866-639-2377 (US) or +1-517-322-0434 (international).
Posted Jul 22, 2024 - 04:18 CDT
This incident affected: Management Portal (Management Portal).