SAT Office Phone Number Issue
Incident Report for Liquid Web - Cloud Sites
Resolved
Inbound Phone Number issue has been resolved. Thank you all for your patience.
Posted 27 days ago. Apr 30, 2019 - 12:26 CDT
Investigating
We are currently experiencing an issue with dialing directly to the SAT office phone numbers. Though if you dial the LiquidWeb line it will direct you correctly.

Lines affected - 1-855-348-9060 & +1.210.581.0407
Please use - 1-800-580-4985.

Thank you for your patience and we will update this post as we have more information. We are available to assist with any questions or concerns via livechat, email at cssupport@liquidweb.com as well.
Posted 27 days ago. Apr 30, 2019 - 11:04 CDT