Degraded Services on affecting Cloudsites

Incident Report for Liquid Web - Cloud Sites

Monitoring

We have implemented the mitigation steps to help keep the service stable, and our Engineering team is continuing to monitor the environment to ensure services remain stable.

All affected sites have recovered and are operating normally. Please feel free to contact our support team if you encounter any further issues.
Posted Jul 21, 2026 - 14:29 CDT

Investigating

We are currently investigating reports of websites loading slowly or being temporarily unavailable. Our team is actively working to identify the cause and restore normal service as quickly as possible.

We will continue to provide updates here as we make progress.
Posted Jul 21, 2026 - 00:51 CDT

Monitoring

A fix has been implemented, and our Engineering team is monitoring to confirm services remain stable.
Posted Jul 20, 2026 - 20:45 CDT

Investigating

We are currently investigating a Website issue with our Cloud Sites Services, which is impacting our hosting environments. Our engineering team is currently investigating the issue at this time.
Posted Jul 20, 2026 - 17:19 CDT
This incident affects: PHP Services (PHX).