We have been monitoring the situation, and everything has remained stable. This incident has now been resolved.
Posted Jul 02, 2026 - 05:36 CDT
Monitoring
We are seeing continued improvement in network connectivity as the affected links begin to recover. All customer websites and servers remain online and accessible.
The scheduled maintenance is still in progress, and our Engineering team is actively monitoring the environment to ensure connectivity is fully restored. We will continue to provide updates as additional information becomes available.
Need help? Chat with us or create a case via my.liquidweb.com.
We appreciate your patience and understanding as we work to restore this service. Thank you.
Posted Jul 02, 2026 - 02:16 CDT
Identified
We are investigating an issue affecting connectivity between our Phoenix Data Center and internal services. We have identified that the issue is related to network connectivity with an upstream provider during a scheduled maintenance window.
At this time, customer-facing services are expected to remain accessible from public networks, and we have not identified a widespread impact to externally accessible services. Our Engineers are actively working with the upstream provider to restore full connectivity as quickly as possible.
Need help? Chat with us or create a case via my.liquidweb.com.
We appreciate your patience and understanding as we work to restore this service. Thank you.
Posted Jul 02, 2026 - 00:26 CDT
Investigating
We are investigating issues affecting servers in our Phoenix Data Center. You may experience connectivity issues. Our Engineers currently investigating the issue to isolate the cause and restore stability.
Need help? Chat with us or create a case via my.liquidweb.com.
We appreciate your patience and understanding as we work to restore this service. Thank you.
Posted Jul 01, 2026 - 23:52 CDT
This incident affected: MariaDB (PHX), PHP Services (PHX), MSSQL (PHX), and FTP (PHX).