Phone Issues
Incident Report for Liquid Web - Cloud Sites
Resolved
At this time the connection to the phone system has been resolved. Fully functionality has been restored and issues identified and resolved.
Posted Apr 17, 2019 - 12:04 CDT
Monitoring
The phone interruption appears to have been resolved. However, we will continue to monitor the situation and provide updates to this post if there are any changes.
Posted Apr 17, 2019 - 11:22 CDT
Investigating
We are currently experiencing issues with our Phone system. If you are unable to reach us please feel free to initiate a chat, create a ticket, or call back later and we will be with you as quickly as we can.

Thank you for your patience and we will update this status with any additional details. We are available to assist with any questions or concerns via livechat, email at cssupport@liquidweb.com, or create a ticket from https://help.liquidweb.com/s/contactsupport
Posted Apr 17, 2019 - 11:12 CDT