Outbound Email Issues
Incident Report for Liquid Web - Cloud Sites
Resolved
This incident has been resolved.
Posted Jul 22, 2021 - 17:09 CDT
Identified
We discovered an issue with a small range of IPs getting blacklisted and are working with our email vendor to resolve that. This should only affect a small set of customers.
Posted Jul 22, 2021 - 11:24 CDT