Hosted Exchange Email Issues
Incident Report for Liquid Web - Cloud Sites
Resolved
This incident is now closed, as our email vendor has notified us that hosted email system is operating as normal.
Posted Dec 08, 2021 - 15:15 CST
Investigating
Our email vendor is aware of an issue that is affecting their Exchange 2013 environment. Mail delivery is not impacted by this, but users may experience an error upon attempting to sign-in to their account via the OWA Webmail. We will provide updates of this incident as soon as they become available.
Posted Dec 07, 2021 - 08:26 CST