Chat Support currently unavailable
Incident Report for Liquid Web - Cloud Sites
Resolved
Our chat provider has resolved the issue and chat support has resumed normal operations.
Posted Apr 19, 2017 - 06:48 CDT
Identified
At this time our chat support application is unavailable. For any pressing needs please contact the Cloud Sites support team directly at 1-855-348-9060 or via ticket through your administrative control panel.
Posted Apr 19, 2017 - 06:16 CDT